PowerObjects Blog 

for Microsoft Business Applications


How to Fix a CRM Workflow Stuck in “In Progress” State


How to Fix a CRM Workflow Stuck in “In Progress” State

Post Author: Joe D365

As you learn about Workflows in Microsoft Dynamics CRM , you may encounter an issue where you find a workflow stuck in "In Progress". You can see an example of this below. Sometimes these workflows might get processed after a long delay.
workflow stuck in

Today we'll go over how to resolve this issue in an on-premise instance of Microsoft Dynamics CRM. The issue might be related to a missing or wrong value in the MSCRM_CONFIG database.

  1. To find out, run the following SQL query and AsyncSdkRootDomain value should be same as the remaining two.

    Select ColumnName, NVarCharColumn
    from
    [MSCRM_CONFIG].[dbo].DeploymentProperties
    where
    ColumnName='ADSdkRootDomain'
    or
    ColumnName='ADWebApplicationRootDomain'
    or
    ColumnName='AsyncSdkRootDomain';

  2. If they don't have the same values, then update AsyncSdkRootDomain value using the following statement. In this '', should be same value as ADSdkRootDomainresult.update [MSCRM_CONFIG].[dbo].[DeploymentProperties]
    set
    NVarCharColumn=''
    where
    ColumnName='AsyncSdkRootDomain'
  3. WARNING: Always backup your databases if you are updating data in SQL directly.

  4. Restart CRM Async Service and the workflows should start working again.

If this doesn't resolve your issue, consider opening a request with PowerObjects for support.

Happy CRM'ing!

Joe CRM
By Joe D365
Joe D365 is a Microsoft Dynamics 365 superhero who runs on pure Dynamics adrenaline. As the face of PowerObjects, Joe D365’s mission is to reveal innovative ways to use Dynamics 365 and bring the application to more businesses and organizations around the world.

3 comments on “How to Fix a CRM Workflow Stuck in “In Progress” State”

  1. And also tell your readers what is the consequence of editing CRM database directly. Just in case that somebody doesn't know it.

  2. We have the same issue on CRM 2016, but just from one entity and this help doesn't work for us. is there any other workaround to do this ?
    In our case, this just happens only from one entity while calling from plugin and its showing in progress. If we configured to call on create or on update work flow is not hitting. I believe Joe can help up . thank you .

PowerObjects Recommends